choke light on, fast idle on and stays that way

I'm having a problem and a severe case of the stupids today. Truck is an 86 chev, 454 & auto. The other day the choke light came on and fast idle came on and
they both are staying on. Gas milage got even worse then it already was.
I've been checking for an obvious short in the wiring but found nothing. Somebody along the line replaced the screws to loosen the choke with rivits.
I disconnected the choke wire and nothing changed.
Anybody have a clue on what might cause all this ? Have pity on me, I'm an old nerd.
Randy snipped-for-privacy@MeinerSolutions.com
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Check the choke/gen fuse in the fuse panel first.

----== Posted via Pronews.Com - Unlimited-Unrestricted-Secure Usenet News==---- http://www.pronews.com The #1 Newsgroup Service in the World! >100,000 Newsgroups ---= - Total Privacy via Encryption =---
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Thanks, I can sure check that.
Use to have a dog named Shep. Good dog. Actually I've had 2 dogs named Shep. Both good.
Randy
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.