Cruise control works some of the time

1990 1500 P.U. The cruise control seems to work 20% of the time? Any suggestions on common problems? Was told to shoot wd40 into the cruise control switch on the steering column. Do think that is a good idea,
could it be the dump switch sticking on the brake pedal?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Don't think the WD would help. Check the little wire harness from the cruise switch where the t/s lever pivots. Could be a broken wire inside the insulation. -- Old Crow "Yol Bolsun!" '82 FLTC-P "Miss Pearl" '74 XLH chopper(gone but not forgotten) BS#133, SENS, TOMKAT, MAMBM
--
Posted via a free Usenet account from http://www.teranews.com


Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
cascadas wrote:

pedal and pull it up. Try to reengage the cruise control. If it will reengage then, there is an adjustment that can be done on the switch. KenG
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I think did the trick, thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
cascadas wrote:

KenG
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.