Cruise on 99 burban

I have a 99 Suburban K1500, 5.7L. Over the past six months the cruise control would shut off while having it set cruising down the road. Now it is to the point where 95% of the time it won't even set. Any ideas on what
I might look for?
Brian
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
you your toes to lift up the brake pedal. then hit resume I'll bet it works again the switch is bleeding off just enough current to trip off the cruise but not enough to light the brakelights
a new switch will fix it

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
So, is the switch right on the brake pedal?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
yes

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Doesn't appear to be the pedal switch. Any other suggestions? Is Cruise control all electronic now days? I remember my old GP used to be vacuum. Wondering if it might be the switch built into the turn signal lever? How does that come off?
Brian

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
the 99 suburban uses a $185 cruise/ wiper/ turnsignal/headlight dimmer module
The 94 and earlier was a $20 handle... oh well its called progress

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I am thinking that it is in that turn signal lever now. Now I am hearing the turn signal relay blinking like the signal is one, although it isn't. Could that be in that whole assembly too?
Brian

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.