fuel regulator

I have a 2000 Tahoe 5.3l the other week . The truck started running rough at idle. I checked the vac. hose to the fuel regulator gas came out. Went to
advanced auto got a new one cleaned out the old one ,only held in by a clip. started the truck now the new fuel regulator is making noise pull off the vac. hose noise stopped. Question is this normal it's quite loud can hear this over engine and fan noise. Did I do something wrong with install seemed straight forward or did I get a bad fuel regulator.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I have a 2000 Silverado, same engine and replaced mine with a Napa part. THe Napa part has some fitting issues but other than that, works fine. Makes no noise. Did you replace the screen and o-ring while you were in there? Can't imagine that's normal for the FPR to make that much noise.
HTH,
Derek
G.W. wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Yes, The new regulator came with new screens and o-ring funny thing is that on first start-up no noise after warm up and a drive noise. Will recheck again tonight for noise.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.