Fuse blows when shifting to reverse

My reverse light/blinker fuse blows when I shift my vehicle into reverse from park or neutral. I think it might be the Neutral Safty Switch. Can anyone verify this, or have other solutions.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Forgot to add it is a 91 Chevrolet Blazer S10
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I had the exact same problem and "fixed" it with a circuit breaker for many years

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I've already changed the fuse, and the flasher. I removed the backup lights, unplugged the harness. For as rapidly as it happened, I'm wondering if it can be the Neutral Safety Switch causing the problem. If not, what else can I check.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I don't have the slightest idea what is wrong after dicking with it for a few days in went the circuit breaker which would pop every time I backed up but, it would reset by the time I had to turn a corner so I pretty much ignored it

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
make sure the lights are not shorted out...replace the backup lites as precaution as i had a shorted filement that did the same thing. make sure you get all backup lites.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.