GMC Jimmy Hard Start

I have a 1998 jimmy that is hard to start and the other day I stooped to get gas and could not start it. It took me two hours to get the jimmy to start. I don't think it is a fule problem, the pump is running and I got
flue past the filter. I pored fule in to the trotlebody and it would start for a minute. Anyone have a clue.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

Fuel pump pressure/flow is low. That fact that it ran when you poured fuel in intake confirms that there is a fuel issue. FUel pumps isse are common of those vehicles at times especailly if you are one to run fuel low a lot. ----------------- TheSnoMan.com
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I know about the pump issue, I have replaced the pump already. After I get the truck starter I do not have any problem with it all day with the exception of the other knight when it took me two hours to get it started again. Do you know what the pressure should be? Spankyg
SnoMan wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

Around 65 PSI from the pump itself. ----------------- TheSnoMan.com
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks The flue pump was the problem. One other question, there is a vent hose on the front of the tank and it looks to be leaking around the vent. My tank is plastic, can this be fixed or do I have to get a new tank.
Thanks again Mike
SnoMan wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

Check out this link
http://forum.snoman.com/viewtopic.php?t $4 ----------------- TheSnoMan.com
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I'm having similar problems with my 1999 Blazer. What fuel pressure readings are you getting? I recently replaced the fuel pump/filter, so it may be a sensor or an injector at this point.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.