Help - Rear Window Washer

re: 1998 GMC Jimmy
When I activate the rear washer the water does NOT get to the wiper arm nozzle. Instead it runs out thru a hole in a rear frame member. I can't
figure out where the tubing is broken or disconnected. Any help is appreciated.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I have the same problem with my 98 Blazer. We just don't bother to use the fluid anymore since I never seem to have the time to try and take the interior apart to find the leak. It was squirting all over the inside by the back window last time we tried to use it. It was in the winter though and I just figured the line was frozen somewhere and that was blocking it from going where it needs to go. Now that the weather is nice... it still doesn't squirt on the window.
Dave

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Dave You gave in. I'm looking to fix the problem as I do like to use the washer occassionally. Rog

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Rog-
Actually, it is my wife's daily driver and she doesn't seem to care so I don't even bother with it. The thing is usually filthy anyways and needs to be detailed so it will look nice. If you find any ideas on causes/fixes for it, let me know.
-Dave

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.