Intermitent Wiper problem

I have an 87 GMC Wrangler, and my wipers are screwed. They are no longer intermitent. When I put it to the lowest settings, it's just on a constant slow speed. And when I shut it off, the wipers won't park. I have to twist
and hold the end of the switch until the wipers are near park position. This sucks. Someone told me it's a ground problem. But I have no idea what to test. Does anyone have any ideas. They would be greatly appreciated.
Thanks Mike
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I'd like to know too. I have gotten very good at parking them myself, I don't even think about it any more.
1985 K5
~TLGM
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Yeah I'm getting used to it I guess. I'm sure glad the wiper switch is not down on the dash like my old piece of shit Ford. Nothing worse than bumper to bumper traffic when there's slush on the road. Not enough road spray to leave wipers on low. So I have to keep reaching down to turn the wipers on for one pass.
Mike
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Keep looking around, you can find jimmyz (and prolly chevyz) with them on the dash :-) I bet if you had a top-of-the-line ford it would be on the column. (But it would still be a piece of shit - just cuz I sez so)
~KJ~

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.