Is it gas line or what...89 Suburban

Hey guys...This lady is in need of help...I had the motor rebuilt in my 89 Chevy Suburban...Thats all good. But now when I start it and it warms up to about half it will die. And it also wont shift into 2or 3
not really sure which one when it warms up. Does any one know what this could be? Any help would be greatly appriciated.
--
Posted at author's request, using http://www.AutoBoardz.com interface
Articles individually verified to usenet standards. Visit URL to contact
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Who put it in?
You know it also would have been cheaper to just buy a rebuilt one.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I would do a fuel pressure check to see if pump is dying because they can run for a bit and then quit. On the tranny, it it was not hooked back up correctly (detent cable for one) it will not shift out of first until about normal max RPM is reached because it may "think" it is at wide open throttle when it is not ----------------- TheSnoMan.com
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
TV cable adjustment for the shift. Sounds like it was streched too tight during installation or it's now in a bind. Check for full release at the tranny--if the cable is bound up somwhere (kinked or crushed) it will result in no movement at the tranny. Dying sounds like unconnected or famaged part on the fuel air system. Don't know what system is on that one. George
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.