It can't be so...can it?

Is it possible that my 93 1500 ck has no dentent cable? Or am I confusing the cruise control linkage for the dentent cable, or...did I take the detent cable off, forgot about and lost it.
My 350 tbi won't go from 2nd to 3rd gear without me letting off the throttle once or twice. I was following the haynes manual and for the life of me I couldn't find a port on the tranny for a dentent cable.
Please help.
Brian
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
May be electronic that year, no cable.

-
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Yep, 4l60e, first year for the pcm contolled units in trucks.

-
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
So I'm hoping, after doing some reading, that my 2-3 solenoid is bad. Any other ideas?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

Yes 93 is kinda bastard year in that both the 700R4 being phased out and newer 4L60 (whch is a 700R4 with a electronic valve body) made it into some trucks. 92 was basically all 700R4 and 94 was all 4L60E but 93 could have either. ----------------- TheSnoMan.com
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I've got the 4L60E. No detent cable. I think the 2-3 solenoid is my problem...I hope.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.