k1500 A/C rapidly clicks on and off, and then dies -what's going on

OK,
My 1994 K1500 has had a recurring problem. Started out that if I had the A/C on and hit a good sized bump, the A/C would click on and off. Progressively
this has gotten worse where the A/C will click on and off in rapid succession several times per second. Now it's pretty much any time I turn the A/C or fan or anything on, and I hit a bump, it starts turning on and off in rapid succession. This may go on for 5 or 10 minutes and then the control unit goes dark and the thing sticks in whatever mode it was in prior (fan high, etc.). Which this turning on and off is an audible click that's coming from the cluster of relays / resisters in the dash.
I first thought this was the controller so picked up a used one at the junkyard but that didn't do anything. I tried wiggling the connections into the relays in the dash and that also didn't do anything.
Only other thing that may help trouble shooting - since this started, I can't get the air to blow out of the front vents, only the defrost and I think the floor vents too - regardless of what the controller is set at.
Any thoughts?
--
Greg

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

A/C
Progressively
succession
rapid
from
into
can't
the
I would look at the connectors really close. It sounds like you are losing power (or ground) to the control unit. In my 91, the controller would wig out and lock into whatever it was in prior to that. What I found was a bad ground wire pin in the connector. It was corroded and broken and losing contact from time to time. It was actually 2 connectors away from the control unit towards the instrument cluster right around the ash tray. HTH.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
"Greg via CarKB.com" wrote: > OK, > > My 1994 K1500 has had a recurring problem. Started out that > if I had the A/C > on and hit a good sized bump, the A/C would click on and off. > Progressively > this has gotten worse where the A/C will click on and off in > rapid succession > several times per second. Now it's pretty much any time I > turn the A/C or > fan or anything on, and I hit a bump, it starts turning on and > off in rapid > succession. This may go on for 5 or 10 minutes and then the > control unit > goes dark and the thing sticks in whatever mode it was in > prior (fan high, > etc.). Which this turning on and off is an audible click > that's coming from > the cluster of relays / resisters in the dash. > > I first thought this was the controller so picked up a used > one at the > junkyard but that didn't do anything. I tried wiggling the > connections into > the relays in the dash and that also didn't do anything. > > Only other thing that may help trouble shooting - since this > started, I can't > get the air to blow out of the front vents, only the defrost > and I think the > floor vents too - regardless of what the controller is set at. > > Any thoughts? > > -- > Greg
Check ALL connections in the circuit and under hood too including ones on cut out switches.
--
Posted using the http://www.autoforumz.com interface, at author's request
Articles individually checked for conformance to usenet standards
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.