left blinker super fast but only with lights on?

Hi all;
I have a 90 model Z71, last night i was coming home and had my headlights on, when i put my right blinker on, it was fine, but when put my left one
on, it went super fast. It was fine with the HL off, even the parking lights made it go fast. I replaced bulbs to no avail, Could it be either the 'brain' (that strip that the bulbs connect to; or the actual plug connected to it? when i wiggle the plug it brightens and slows some, but still not correctly. I've checked all the ground wires i can find, any help would be greatly appreciated.
Thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

help
The early to mid 90's FS trucks are notorious for tailight circuit board (what you refer to as the "brain") failure. Dealer cost is around $80/side, last I checked Autozone had em' for $30/side. Sounds more like a shoddy connection than circuit board failure though. Usually with CB failure your turn signals will turn on yer' reverse lights, braking will light up the turn signals, all kinds of weird shit.
Doc

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Had the same symptons happen on our 99. They ( stealer ) replace d the circuit board on the RR tail light. In our case, it was the RR that was acting strange.
ML
--
BlankPage
""Doc"" < snipped-for-privacy@noway.com> wrote in message
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Re: left blinker super fast but only with lights on? Group: alt.autos.4x4.chevy-trucks Date: Mon, Oct 6, 2003, 1:05am (CDT+1) From: snipped-for-privacy@comcast.net (todd) Had the same symptons happen on our 99. They ( stealer ) replace d the circuit board on the RR tail light. In our case, it was the RR that was acting strange. ML
--
BlankPage
""Doc"" < snipped-for-privacy@noway.com> wrote in message
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Blinker fluid must be getting low, mine ALWAYS does this when it's low.. :P :D
Adair
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Re: left blinker super fast but only with lights on? Group: alt.autos.4x4.chevy-trucks Date: Mon, Oct 6, 2003, 8:44pm (CDT+5) From: snipped-for-privacy@hotpop.com (AdairWinter) Blinker fluid must be getting low, mine ALWAYS does this when it's low.. :P D Adair
Could be but the damn filler tube is so hard to get to .Checking it is almost impossible anymore.........
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Could be but the damn filler tube is so hard to get to .Checking it is almost impossible anymore.........
THERE IS A FILLER TUBE??????????????????
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Re: left blinker super fast but only with lights on? Group: alt.autos.4x4.chevy-trucks Date: Mon, Oct 6, 2003, 11:45pm (CDT+5) From: snipped-for-privacy@hotpop.com (AdairWinter)
damn filler tube is so hard to get to .Checking it is almost impossible anymore......... THERE IS A FILLER TUBE??????????????????
LOL
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
~~~ left blinker super fast but only with lights on? Group: alt.autos.4x4.chevy-trucks Date: Sun, Oct 5, 2003, 7:37pm From: snipped-for-privacy@microxl.com (Sundance)
Hi all;
I have a 90 model Z71, last night i was coming home and had my headlights on, when i put my right blinker on, it was fine, but when put my left one on, it went super fast.
It was fine with the HL off, even the parking lights made it go fast. I replaced bulbs to no avail.
Could it be either the 'brain' (that strip that the bulbs connect to; or the actual plug connected to it?
When i wiggle the plug it brightens and slows some, but still not correctly. I've checked all the ground wires i can find, any help would be
greatly appreciated. Thanks ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ Mr Redford, if the wiggle test changed the results in ANY way......then start your diagnostics there.
REPAIR KNOWN BAD FIRST.......... then.....proceed to the next item on the flow chart.
always a sound diagnostic technique.
Scribs Abell (are you)
~:~ wonder if i could get a part in the next film~:~
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.