MAP Sensor in '02 8.1L

2002 Chevy 8.1L, 30K miles
Scenario: Two times early last week and once this week the engine has just died for no reason and restarted without issue.
First time it died I was rolling at 40 MPH in a coast, it died and while rolling started on it's own again, NO KEY TURN, like popping a clutch.
Second time it died slowing to about 10 MPH under light braking. This time it took a few seconds to restart using the key, but it did restart and ran great the remainder of the week.
Third time was yesterday, again sitting stopped at a light. Started right back up and has not skipped a beat since.
NO Codes in the computer, at least none scannable by a basic scan tool.
Questions: Will the MAP sensor act like this? Is it the likely culprit? If it is scanned by a dealer's computer, will they definitively be able to tell how the MAP sensor is working?
Odd thing is this tank of gas also seems to be getting better than usual mileage out of it.....
I'm thinking about making the $50 gamble and replacing it.
Thoughts?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
maybe the fuel pump. that is what happened to me.
K wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Why do you suspect the MAP, that is the least likely to cause this, the truck will run if it was disconnected. How did it stall completely and the starter re engage the engine? Sounds more like it stumbled to the point the engine dropped off but then popped back up before quitting. GM has had ign. sw. issues, but the diagnosis here could be problematic.

-
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.