Need Delco radio help..please!!

I've googled this to death but thought I would give this one last try here.
I have a 1996 S10 Blazer with Delco radio model #16169165. I can see that
the previous owner must have installed a different stereo & then when they traded it in, replaced the Delco.
I bought the car a month ago and its fine except the radio memory does not store any station setting or time. It has three plugs- black, blue, and white. An orange wire in the black plug supplies 12 volts while the key is in the ignition. There are no other voltages present in any plug with the key off.
With those 3 plugs in the back of the radio there is still one open socket with 7 pins I believe. But there are no other loose cables anywhere to be found in the dash. Is the 12 volts necessary to keep the memory supposed to be through this plug?
Unless someone has any ideas, my only hope is to apply 12 volts to each of those pins to see if the memory keeps without frying the radio.
Someone suggested that the radio might have an internal battery, but I've taken the covers off and don't see anything resembling a battery.
If you have any ideas please let me know!
TIA, Steve
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Mr. Transistor wrote:

try
http://carstereohelp.net/wireharness_Delco1.htm
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Well first off if you just bought it take it back and have them fix it. There should be a 30 day warranty or something like that? Now if you don't have that I'll see if I can find a wiring diagram. Feel free to email me if you need more help.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.