Need help with ABS problem

My fiancee has a '01 Blazer, recently thew ABS system is faulting somehow. While driving and coming to a stop, once I pess the brake pedal, there is a very loud grinding or banging noise, as the vehicle
stops the peddle pushes back toward me. sometimes at this point the brakes dont engage or engage very sluggishly. I gave replaced all the pads and still the problem exists. if I disengage the ABS system by unpluging the wire harness on the unit, the car brakes fine. Any Ideas on fix and on cost? Thanks in advance.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
bluefiero wrote:

Probably a front wheel speed sensor, 1 or both are bad.....
2000 Silverado sized sensor item cost $62 wholesale each or $110 GM retail each...
Plus labor......
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I got a recall notice for mine ('00 Silverado)... I would check with a dealer for recalls, first. David

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Thu, 10 Aug 2006 14:02:03 -0500, "David Courtney"

Remove the x for e-mail reply Amateur radio enthusiast, N9JBF Bass fishing Aficionado! www.outdoorfrontiers.com www.SecretWeaponLures.com A proud charter member of "PETAF", People for Eating Tasty Animals and Fish!!!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.