no spark

I have a 1989 chevy silverado pickup. Driving home from work one day, the truck died. In the process of troubleshooting, I noticed I had no spark to
the plugs. I replaced the wires, plugs, distributor cap, and rotor cap and still have no spark. I am getting fuel since I can smell it accumulating in the carb when I turn the engine over. Any suggestions?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Ign module or pick up in the dist.

-
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Yep, it was the Ign module. thanks...
Shep wrote:

--
Message posted via CarKB.com
http://www.carkb.com/Uwe/Forums.aspx/chevrolet-trucks/200606/1
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
--when that happened to mine it turned out to be a bad coil. Tests for it in the manual are bogus. It tested good according to manual, yet it had a high voltage arc-over internally. Spoke to some mechanics about it since and they mentioned a few failures of the coil they had seen. ------------------------------------------------------

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
It was the ignition module. Thanks anyway.
snipped-for-privacy@verizon.net wrote:

--
Message posted via CarKB.com
http://www.carkb.com/Uwe/Forums.aspx/chevrolet-trucks/200606/1
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.