oil pressure

just got my 454 running all rebuild and still trying to break in engine. I prepumped the oil pump and start the engine up. looked at the oil gauge and
it didn't go up. i shut off the engine and pull the side plug on top of oil filter disable the spark and and turn it over oil was coming out of the oil port so i know the oil pump is doing its job. i have the pressure gauge out back of motor where the cam is. is there another place i can put the gauge? its a mark 6 454 with 10w-40 oil (recommanded by the racers)the oil gauge i have now will not go in the oil port above the oil filter. the fittin gis too big and there is no adapter for the oil gauge i'v looked for one found nothing to adapt the oil gauge to. the oil gauge has a small tube to the oil gauge i weas also wondering if the oil is too thick to travel the oil tube.
the riddler mark 6 454 600hp bored .060 high rise intake 800cfm carb 11:1 compression
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
FInd a good pickup that fits in the proper port.
A cheap mechanical gauge will fit.
Sam

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I also had this problem, it turned out the engine ground for the instruments wasn't grounded enough (flat braded wire at back of engine).
Clint

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Do You Have A Machanical Gauge If So Did You Bleed The Line On The First Start, I'v Had That Happen All We Did Was Disconnect the line ran the engine till oil came out reconnec ted it and started it again it was reading great
CN.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.