Opinion On Brakes?

88 S-10 Blazer 4x4 4.3 A/T Power Brakes.My brake pedal seem to be slowly creeping to the floor while sitting in traffic.I know this can be a sign of master cyl.going bad,but also the porportioning valve was leaking a
little.So I replaced both M/C& P/V.I also bench bled the mc before installing.Bled the brakes got a full pedal,started the eng. pedal goes almost to the floor.The emergency brake light is working,because it comes on when I bleed the lines on pedal pressure.The back part of the mc bubbles up when pressure to pedal is applied.So I installed another mc and the same thing.I think I know what it might be.I'm hopeing anyway,but before I say ,I would like to get some of your opinions?Thanks! Bobby
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Sounds like you still have air in the lines.
The brake hoses on the front can become restricted by the support bracket when it rusts and strangles the hose. Check to see if the front brakes release immediately when the pedal is released.
Check the rear brake hose.
Also check the rear brake adjustment, perhaps the self adjusters aren't working.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Maybe the power booster is shot happened to my surburban too..Dionysus

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.