PING Steve W. Under hood connector

1997 GMC Yukon SLT 4dr 4X4 Had both heads replaced recently and it runs great, but there is a unplugged connector on top of the engine that I never noticed before.
It breaks out of the harness just to the driver side and slightly forward of the throttle body. It's a two wire connector with a blue wire and a black wire with white tracer. For the life of me I can't find a connector to plug it into. All-Data is no help because I don't know what I'm looking at. Any ideas Steve? Guys? Regards, JR
--
Left to the realities of the free market,
the oil industry can take care of itself
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
JR wrote:

Only one I can think of would be the A/C high pressure cut out switch.
That one is Dark blue and Black W/ white stripe.
Plugs into the back side of the compressor under the lines.
--
Steve W.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks Steve, I'll look again in the morning. Regards, JR
--
Left to the realities of the free market,
the oil industry can take care of itself
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.