Remote door transmitter

2000 GMC Z71 Remotes for door locks stopped working suddenly. I checked batteries and even tried a second transmitter. Also checked fuses and tried to reprogram
by holding both buttons down like the owners manual states. Controls on door work fine. Anyone have any ideas?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Sounds odd that you'd have to re-program the transmitters. Have you replace the truck battery recently? Have you had problems with it?
Here's the program procedure:
1. Start with the ignition OFF, hold down the power unlock button on the door panel. Turn ignition key ON, OFF, ON, OFF. Release power unlock button on the door panel. The locks will cycle once. 2. Hold down the keyless entry transmitter LOCK and UNLOCK buttons for 15 seconds. The locks will again cycle once. 3. Repeat step #2 for each additional keyless entry transmitter. 4. Turn the ignition on to exit the keyless entry transmitter programming mode. Programming is now complete.
If that doesn't work, you may have a problem with the RKE module. It's not in the easiest of places to get to, it's under the dash cover, on the TOP of the dash.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
You said controls on the door work fine. Did you try the passenger door? I recently had to have my right door module reprogrammed by the dealer under warranty (03 Chevy Z71). All of a sudden the transmitters stopped working and nothing on the passenger door worked (windows, locks, button lights). Just a thought.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks alot Mike, They work fine now. I wasn't looking forward to taking the dash apart. By the way, I did not replace the battery or have it disconnected. My remotes just stopped working suddenly at a shopping center. Thanks again.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
You had to re-program the transmitters? Glad I could help...
wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.