replaced throttle body but injectors still not shooting fuel

1990 chevy silverodo 4x4 will not start cause fuel problem. replaced fuel pump, fuel filter, fuse pump relay and throttle body. however the the throttle body is getting fuel but the injectors are not shooting fuel. And
we are out of ideas....
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Did you check for strong / perfect spark with a spark tester or timing light?
No spark means no reference pulses....no reference pulse means closed injectors. You could have a bad ignition component.
Also, any MIL codes?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
We used a test light and injectors have power. however still not shooting fuel. Can the pulse timing be off? how would you know if the injectors are closed? Or could it be a pressor problem? how do you check the pressor?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

No spark no reference pulse no fuel. Definitely check for spark. We just had that a couple of days ago on our one truck, drove it home parked for ten minutes then no start... no fuel. Changed the module in the distributor and fired right up. Second truck we had to replace module in the last year. Both had no fuel out of injectors...
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I assume you've checked the ECM for codes and correct function? No ECM signal = no injector pulse.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
ok well i put a code key on the truck and the service engine light blinked once and then it blinked twice. which i am guessing is code twelve. i looked it up and it is the speed sensor. do you know if that would keep my injectors from spraying fuel?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
12 is normal, not a code.

-
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

12 is a code but a normal code with the key on and engine not running. It is used as a normal benchmark because it is typical and makes sense.
OP: We used a test light and injectors have power. however still not shooting fuel.
Can you describe this test more? You have to test the injectors with a low amp draw LED NOID light. A test light may over current the driver.
OP: Can the pulse timing be off?
Not sure what you mean but I don't think so.
OP: how would you know if the injectors are closed?
Fuel pump running....no fuel spraying or dripping out.
OP: Or could it be a pressure problem?
Maybe
OP: how do you check the pressure?
You can check the pump dead head by connecting a gauge to the filter connection. To check the regulator, you'd have to "tee" into the system and run the pump/engine. The pump really has be flowing to check this. Others who do this for a living might comment the details. You also need to test for FLOW but that is probably not an issue for you because you can't even start.
Have you CAREFULLY added a little gas down the throat to see if it will run with "extra" fuel?
skimmer
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
======== ========

======= =======
Change the ign. pickup and module........
take 2 asperin
call me in the morning
PS
the injectors are ground controlled by the ECM (in case of confusion....read yer own thread)
:)
~:~ MarshMonster ~sips his CrownRoyal...takes a hit off his pipe..... mmmmmm......good stuff~ ~:~
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

============ Change the ign. pickup and module........
take 2 asperin
call me in the morning
PS
the injectors are ground controlled by the ECM (in case of confusion....read yer own thread)
:)
~:~ MarshMonster ~sips his CrownRoyal...takes a hit off his pipe..... mmmmmm......good stuff~ ~:~
Exactly....
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Related Threads

    Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.