roaring sound while accel, but not coasting

My 1985 Chevy S10 4x4 2.8 is making a roaring sound when I'm accelerating but goes quiet when I ease up on the pedal and coast - it is very noticeable - I just had my front wheel bearing replaced because my mechanic
said that it needed it - this did fix some noises but not this one
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

that the clutch isn't operating properly. When mine failed, I got the same effect you're describing.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
From the front, back, middle, give us at least a hint here. Your in the truck we are not!

-
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
don wrote:

Standard Tranny or Automatic..
if Standard Tranny Check the oil in it
Also RUSTED out Body mounts .. Body is Sitting on the Tranny

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
This is an automatic and I would say the noise is coming from the back but it's hard to say - it seems to drive fine

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
don wrote:

check the GREASE in the REAR END

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
If he is running GREASE in the rear end that is the problem :) Maybe check the pinion slack. 85 you might get away with reloading the pinion bearing and drive it. Pinion could be moving when decelerating causing mis alignment of pinion and ring. Inspect the ring for new wear marks.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.