Silverado 4 x 4 Transmission problem PLEASE HELP!!!

We replaced the transmission with one from a 2006 silverado. Wiring is all the same the only thing we had to change was the park, neutral position switch. The problem we have is the trans will not up shift
and the speedometer is not registering. The ABS and Brake lights also came on and they weren't before the swap. ANY suggestions would be great as I am lost to this point.. thanks in advance.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I think you're missing some critical information here....like what year, make, model, and engine the original vehicle was.....
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Sorry, 1999 Chevy Silverado Ext Cab 4X4, 5.3 Liter, 4L60E Transmission.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Thu, 17 Jan 2008 04:47:39 -0800 (PST), snipped-for-privacy@gmail.com wrote:

sounds like the computer ain't getttin' the speed sensor info from the new trans. -- Old Crow "Yol Bolson!" '82 FLTC-P "Miss Pearl" '95 YJ Rio Grande BS#133, SENS, TOMKAT, MAMBM
--
Posted via a free Usenet account from http://www.teranews.com


Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

the VSS the same? I think a 99 is looking for a 4K VSS signal but I don't know what the output is on a 06. Might want to swap in the VSS from your original tranny. My opinion is either a wrong VSS, bad VSS or maybe you stretched and broke the wires to the VSS.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

Keep in mind I am not fortunate enough to be looking at factory manuals. Pulling it off the top of my head. There could be other problems. Have it scanned, find out if there is a VSS signal. On a 700R4 both mechanical and optical VSS's were in the T-case. I THINK they were moved to the tranny body just in front of the T-case/tailshaft flange on the E models. If the VSS output is diffrent, IF, it won't change with a sensor change, you have to swap the reluctor ring or the buffer. I may be way off but its something to look at.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Thanks for all the reply's. We found a wire up near the bell housing that had came apart, must have hit it when putting the dipstick back in. Thanks again.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.