Stall after Start

I have a 95 GMC with th 5.7L TBI. When you re-start the truck hot, it will start them innediatly die. Crank the starter for a while and it will re-start with an erratic idle and then smooth out in about 10 seconds. It
only does this after sitting hot for 20 or 30 minutes after stopping the engine. Cold start, no problem. Turn truck off and re-start in 10 minutes, no problem.
help :(
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I had the same symptoms on my 93 4.3.
I narrowed it down to the ignition module.....so rebuilt the distributor (p-u coil, module, etc.) and replaced the cap, rotor, and rusty secondary coil. So far, so good.
I'm pretty sure the main culprit was the ignition module......it did test bad on the high tech testing machine at Advance Auto.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
check pluggs for foulin wires for arcing and burned areas...cap an rotor for carbon build up..check fuel pressure..9 to 14 psi with key on engine off...check IAC..remove an clean...check TPS..then check for vacumm leaks..replace cracked or dry rottled hoses..check EGR..quick diagnose would be to plugg off EGR and see what out come is..still stalling EGR is good..move on to ECT..engine coolant temp might be the culprit here..get engine to opeeratin temp ..unplug the ECT..and start the engine..drive..does it die..if it doesnt die then you found your problem...
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.