Strange loss of power

My exhaust flanges started getting bad last month so I got them fixed the other day along with taking off the catalytic converter and adding a resonator. But anyway sometimes when I force the fuel to my 91 4x4 GMC 1/2
ton she hesitates to go and bucks then when I let got the fuel she is perfect. No codes show up just the loss of power. Anybody care to answer this one with opinions?
Darryl
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
fuel filter
change it and get on with life

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Done it last week. Life still hard to get on with...
Sarcasm will get you no where man!!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
check fuel pressure ?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
"Dthenewf" wrote

That information would have been more useful in the original post. Anything else that you've done that you haven't mentioned?
Ian
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Actually those that offer free help can be sarcastic. Hell if he helps me why do I care? And he's not trying to get anywhere.
Brian
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.