trouble code p0304

I was driving my suburban this evening and when I got on the highway every thing was fine until I hit 70 mph .Then it kind hesitated for a min are two
and the SIL came on.went to AutoZone pull the code and there was 2 codes and both was p0304 cylinder 4 misfire.
Some other strange things has happened not to long ago in short , it cut off on me doing about 35 mph ,and wife said it was hard to start for her a few days ago.I plan on changing out the fuel filter this week end,
It's a 99 k1500 suburban with about 111000 miles on it.I put new plugs in it around 90,000 and a new fuel filter at the same time. I plan on replaceing the wires?as far as I know there still factory. Out side of that I'm lost.
What else could thhis be?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
My email setting are wrong. It supose to be snipped-for-privacy@yahoo.com

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
These engines can eat up non -oe plugs, I had Bosch plats in mine that were done at 20k. Pull # 4 plug and take a look at it and the wire also.

-
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Ok can you tell me which is the number 4 cylinder.If im standing facing the engine?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
2cnd cyl from the front on the pass. side, but check the numbers stamped on the Int. man.

-
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I have seen this problem a few times and it always was cured by CLEANING THE BATTERY TERMINALS real well. remove,scrape with a blade or brush, both terminals and battery connecters. use baking soda paste to wash all corrosion , then rinse with water and remount them
old john

two
and
off
it
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
It had a new battery put in about 4 months ago and put on new connecters but I will check for corrosion

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thank every one for tring to help but now after I did check the things out the spark plug was slightly bigger than suppose to be adjusted it back down, but now I dont have a problem any more due to some SOB stole the F@#king thing last night.But any ways thank yall maby they will find the dickheads that done this

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I've got the same problem with my 99 GMC jimmy, cylinder 4 misfire.

every
two
a
in
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.