truck not running (fuel problem) PLEASE HELP

it is a 97 K2500 with a 350. the other day i was driving about 30mph or so and my truck hesitated a little and stalled.... I came to a stop and it started right back up.... ran fine the next day and then died again and
wouldnt start...... i replaced the fuel pump and sending unit and still nothing....... some people say that i could have gotten a bad pump from NAPA but i have no idea........ if gas is put in the throttle body it will start for a minute and stall when it runs out.... ANY IDEAS
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Check fuel pump relay and make sure pump is getting power.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
i havent checked the relay yet.... but the pump is getting power cause it is giving 20psi of fuel pressure... so its like it isnt getting enough
SnoMan wrote:

--
Message posted via CarKB.com
http://www.carkb.com/Uwe/Forums.aspx/chevrolet-trucks/200603/1
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Check to make sure the pump is getting power. Did you also replace the filter?
Dave
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
i replaced the filter and pump and sending unit. it has 20psi fuel pressure which isnt enough..... i am lost Hairy wrote:

--
Message posted via http://www.carkb.com

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
u could also check the throutle body to make sure the injectors rnt stoped up. i have seen that a lot
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
What is the fuel pressure?

-
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
its only getting 20psi for fuel pressure...... i have no idea why
Shep wrote:

--
Message posted via http://www.carkb.com

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
My brother has a 1997 ,1500 , 4x4 and his truck is experiencing the same problem. A mechanic friend has recommended changing the fuel pump again. The pump failed in late 2004.
Filter replaced twice, no fuel pump pressure right now ( however the pump does supply some fuel to the fuel rail)
If you feed the throttle body fuel it will run for a few minutes then stop. After other websites mention the fuel pump again we are going to replace it again. However we are also looking into a problem with the Fuel Pressure regulator? It appears to be under the throttle body and within the intake? any other clues .
thanks Chris

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.