Two questions about S10

My car: S10 from 1994
Problem no. 1:
When I start in cold whether (5-10C) there are an odd clonking or banging noise emerging from the front of the motor compartment. The noise follows
the speed of the motor and sounds as if it makes one "clonk" pr. revolution. The noise disappear as the motor reaches operating temperature.
What can that be?
Problem no. 2:
The car pulls slightly right when I drive and let go of the steering wheel. I have had the auto repair shop look at it several times, but they can't make it go straight. There is no difference in the magnitude of the problem when I either apply the brakes or the speeder. All the balls, joints and top bearings have been replaced recently in the front and there are brand new tires on the car.
What do I look for?
Best regards
//zigge
Denmark
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Have you had a wheel alignment???

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Inline............

What weight of oil are you using?

You need an alignment.
Doc

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

or a straight frame................
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Does the engine use any coolant? What weight oil is in it? When was it changes last? When it starts is there a lot of BLACK smoke that clears up rapidly?

on the wrong side of the EMPTY road that it normally pulls on) or, Right front tire low, Rear thrust angle wrong due to bad bushings,bad center pin,bent shackle. Frame twisted or racked.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.