Up Coming Problem?

'04 GMC 2500HD 6.0 8500 miles Every once in awhile,after driving 25+miles,when I come to a stop,tach drops down to about 500 rpms and the motor starts to shake.Never died
until yesterday. It started right back up,and has been fine since. I didn`t see a service engine light or any other lights,but did scan for codes anyway.There were non. I know it`s under warranty,but I`m sure if there are no codes,dealer will have it all day and find nothing. Any ideas or things to watch for?
Thanks, Bill
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Clogged fuel filter already?
OUS

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
That couldn`t be it or could it? That would be to simple.
Bill
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Easy to test but I don't think that's the problem. Just go out on the highway and cob it. If the pump is bad it will fall down. Did the problem return?
Al
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
No problems for the past 2 days now. Everything seems fine,but there must be something going on.
Bill
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The other thing I noticed,is that it only has a problem when it rains. Do I maybe have a plug wire arcing? Only thing I can think of.
Bill
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.