vortec 4.3 serpentine belt tensioner

Hi,
I have a question regarding the belt tensioner on a 4.3L HO vortec v6 for a 98 chevy s-10 zr2. I had it replaced last year with my serpentine belt which
was getting cracks in it. Since then, every once in a while after taking a long drive and then sitting at idle, I hear what sounds like a clicking noise, and when I open the hood, I can tell that it is coming form the tensioner, as it moves back and forth on the belt. Now when at cold idle even it sounds a little bit off, like bearings in there are bad or something, as there is a constant rattling sound from it.
Is this normal? I dont recall that on the original one.
Is there much warrantee recourse for stuff liek this, done by chevy dealers, less than a year and less than 10k miles ago?
Thanks,
JMH
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
"JMH" wrote

dealers,
You can either replace it or live with the noise. This is a very common complaint on these trucks and we replace numerous belt tensioners.
If it was mine...I'd live with the noise and just keep an eye on how loose the tensioner gets.
Ian
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks for the info... Actually, I paid for brake fluid flush at the same time (this past march), and when I opened it up today (I just got a motive power bleder), and noticed it to be really dark and had some crystalline junk floating on top... It hasnt been flushed, and Im going back to the dealer. Might as well have them change that on warranty, as Im unhappy that it has turned bad in less than a year and less than 10k miles. Thanks for the info,
JMH

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.