Wrong NG, but help greatly appreciated!

I know this is the wrong place to ask, but I couldn't find any Buick groups.. Many thanks in advance to anyone who can help tho...
86 Buick Grand National GNX
60,000 miles, some performance parts, nothing done to tranny tho. reg. maintenance. Got it in 1990 with 15K on it.
I changed the tranny fluid+filter last week as I don't think it had ever been done or atleast I've never done it. the old fluid+filter didn't look bad but at 60k i felt it was time to be done. Topped it off to the correct levels and used correct fluid to mfgr specs and I didn't touch anything else when i had the pan off. Anyway, I took it out on a test drive and all is good. shifted firmer etc so I came home, put it in reverse to back into the drive way and it jerked and then it was like it was in neutral. So it seems reverse is completely gone. Drive, 1, 2 etc are all fine. still shifts wonderfully but reverse is gone. what could've happened? possibly a pre existing problem? thanks again.
AA
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

groups..
been
but at

used
the pan

etc
and
gone.
gone. what

while not a solution, my '99 silverado has started to act up ever since i did a fluid and filter swap over to synethetic. I haven't lost any gears, but, when down shifting sometimes it pulses like the the TC is going in and out of lock up.
Adair
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
What trany is it
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.