2002 TL-S engine miss/bucking

Any of you guys run into a low speed miss on 2002TL? It started 2-3 mos. ago . First occasionally, now everyday. At about 25-35 mph and light throttle,
the car starts to buck until you change throttle positon, then it responds normal. It runs fine at full throttle at least to 115 mph and idles smooth, Avg. mileage around 25 mpg, same as always. Has 72K mi. on it. Gonna pull the plugs and go from there. Thanks!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Sans wrote:

---------------------------
How often have you been feeding it injector cleaner?
'Curly'
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
DQoibW90c2NvXyIgPG1vdHNjb19AaW50ZXJiYXVuLmNvbT4gd3JvdGUgaW4gbWVzc2FnZSBuZXdz OjEzNTRpbDBhN2M5anM4NUBjb3JwLnN1cGVybmV3cy5jb20uLi4NCj4gU2FucyB3cm90ZToNCj4+ IEFueSBvZiB5b3UgZ3V5cyBydW4gaW50byBhIGxvdyBzcGVlZCBtaXNzIG9uIDIwMDJUTD8gSXQg c3RhcnRlZCAyLTMgbW9zLiBhZ28gDQo+PiAuIEZpcnN0IG9jY2FzaW9uYWxseSwgbm93IGV2ZXJ5 ZGF5LiBBdCBhYm91dCAyNS0zNSBtcGggYW5kIGxpZ2h0IHRocm90dGxlLCANCj4+IHRoZSBjYXIg c3RhcnRzIHRvIGJ1Y2sgdW50aWwgeW91IGNoYW5nZSB0aHJvdHRsZSBwb3NpdG9uLCB0aGVuIGl0 IHJlc3BvbmRzIA0KPj4gbm9ybWFsLiBJdCBydW5zIGZpbmUgYXQgZnVsbCB0aHJvdHRsZSBhdCBs ZWFzdCB0byAxMTUgbXBoIGFuZCBpZGxlcyBzbW9vdGgsIA0KPj4gQXZnLiBtaWxlYWdlIGFyb3Vu ZCAyNSBtcGcsIHNhbWUgYXMgYWx3YXlzLiBIYXMgNzJLIG1pLiBvbiBpdC4gR29ubmEgcHVsbCAN Cj4+IHRoZSBwbHVncyBhbmQgZ28gZnJvbSB0aGVyZS4gVGhhbmtzISANCj4gDQo+IC0tLS0tLS0t LS0tLS0tLS0tLS0tLS0tLS0tLQ0KPiANCj4gSG93IG9mdGVuIGhhdmUgeW91IGJlZW4gZmVlZGlu ZyBpdCBpbmplY3RvciBjbGVhbmVyPw0KPiANCj4gJ0N1cmx5Jw0KR29vZCBhZHZpY2UuICBVc2Ug VGVjaHJvbi4NCg=
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.