'91 Integra whines like a truck

Just started doing this. A whine that sounds like a truck transmission. It follows the speed of the engine. It sounds like it's coming from the right front engine area (as you face the engine compartment). I figured
belt? water pump? 145K. Anybody have a clue who's had a similar problem? I did an exorcism last night, so the possesion freaks please stay away :-)....
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On 28 Dec 2005 06:56:01 -0800, finding z0 said:

Could be a wheel bearing.
--
"I refuse to answer that question on the grounds
that I don't know the answer."
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
finding z0 wrote:

timing belt just about to fail. stop running it immediately! replace belt [and pump while you're in there]. go to tegger.com for links on how to do the job yourself. buy the helm manual as well.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Did not know timing belts gave you a warning - good info. Had one to go on an 80 accord - on starting - no valve damage.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
butch burton wrote:

only if you're lucky! if they're slack, they're quieter & less likely to make noise.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Into Honda tomorrow. I had the belt changed at 90K. I thought after 100K no more miantenance was needed...;-)
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I changed the brushes on the alt. in the summer. Wondered if it could be the alt?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
It wuz the AC idler pulley $43 part, $109 work...
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Thanks for the feedback!
Mike
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.