92 Acura Vigor starting issues...

Hey, I have a 92 Acura Vigor GS (AT) that wont start in park. It used to, of course, but after a while, I had to jiggle the trans shifter to get the ignition to start. Then, I eventually had to put
the car into neutral to get it to start, and now its progressed to the point where I have to gently pull the shifter down from neutral towards drive before the ignition will hit. I heard it could be a Neutral Safety Switch, but any other help would be greatly appreciated.
--
Posted using the http://www.autoforumz.com interface, at author's request
Articles individually checked for conformance to usenet standards
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Does simply wiggling the ignition key (or pushing it in while wiggling) help at all?
If not, then your Neutral Start Safety Switch is probably out of adjustment or in need of replacement.
--
TeGGeR

The Unofficial Honda/Acura FAQ
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
do you know anyone lookin for a integra motor 92 low miliage please email me at snipped-for-privacy@aol.com
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
do you know anyone lookin for a integra motor 92 low miliage please email me at snipped-for-privacy@aol.com
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.