94 integra idle drops when hot

I have a 1994 accura integra and the idle drops when its hot. I adjusted the valves, changed the IAC and plugs. I still have the same problem. Please help.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Mine always did that (91) Isn't that normal?
Vlad
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Well the idles drops to around 500 rpms. Idle should be 750 rpms. Any answers?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

How clean is the throttle body?
Make sure it's clean, then set the base idle correctly:
1) Uplug IAC 2) Drive car until warm (ignore Check Engine light) 3) Turn idle screw until idle is at 650rpm (assuming manual tranny) 4) Plug IAC back in. Idle should stabilze at 750
Is the IAC actually working? When you turn on an high-load accessory (A/C, rear window defroster, etc.) does the idle drop a bit, then go back to where it was? When you turn off the accessory, does the idle climb slightly, then drop back to where it was?
--
TeGGeR

The Unofficial Honda/Acura FAQ
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Well when I turn on the rear window defroster the idle stays the same. It didn't drop and come back up. I didn't get to try the a/c, it's not working now. I notice when I'm at a stop and the idle is low if I put in 2nd gear or netural the idle goes back up to around 750 rpm.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Did you adjust the idle as I said?
With the engine full-warm, all accessories off, and the IAC disconnected, it should be 650rpm in neutral.
--
TeGGeR

The Unofficial Honda/Acura FAQ
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
And the throttle body is very clean.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.