'97 RL: Heater problem

My car blows cold air on idle when I have the heat turned on. When I drive the veh hot air is blown. The problem is only at idle..Can anyone help me with some ideas as to what's going on? Water pump?
heater core?
Add pictures here
âś–
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
ruff_ryder snipped-for-privacy@hotmail.com wrote in

Thermostat. Replace with OEM only.
--
TeGGeR®

The Unofficial Honda/Acura FAQ
  Click to see the full signature.
Add pictures here
âś–
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Could be low on coolant causing this but the question is where did the coolant go?
David Short Acura God

Add pictures here
âś–
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Good point. you're suggesting poor circulation, normally a consequence of low coolant level.
If this were the case, I would expect the OP would experience increasing engine temperature (overheating) during prolonged idling, wouldn't you?
--
TeGGeR®

The Unofficial Honda/Acura FAQ
  Click to see the full signature.
Add pictures here
âś–
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
TeGGeR® wrote:

yeah the engine temperature is normal at the middle... would it be the temperature sensor then?
Add pictures here
âś–
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

yeah the engine temperature is normal at the middle... would it be the temperature sensor then?
Did you at least check your coolant level? I have had problems like you described and it only caused the engine temp gauge to soar when the coolant got very low.
--Art
Add pictures here
âś–
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
i just checked my coolant and its at max...i probably will get my thermostat replaced its not gonna cost a lot i hope
Add pictures here
âś–
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
ruff_ryder snipped-for-privacy@hotmail.com wrote in

Thermostat is about $20. Labor I dunno.
You NEED to replace it.
--
TeGGeR®

The Unofficial Honda/Acura FAQ
  Click to see the full signature.
Add pictures here
âś–
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.