Acura 2007 RL

Drive about 300 miles cruise set at 75, no problems. Come to a stop at toll booth and pick up the ticket. As I take my foot off the brake and start to
accelerate the car starts bucking like a bronco, tach fluctuating wildly between 500 and 4000 rpm. It's hunting for a gear and can't find one to engage. Towed into nearest Acura dealer 40 miles away. informed no one working labor Day weekend. They graciously give me a loaner. Anybody got any ideas what the problem is? ps - the fluids were all checked and changed/topped off in May. Thanks for your input
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Did you happen to notice whether the D trans light on the dash was blinking?
Did you turn the car off and turn it back on to see if that cured it?
Are you sure it was fluctuating wildly like THAT, and not simply between, say, 500rpm and 1500rpm? maybe 2000rpm?
you're under warranty, which is good. It could be transmission related. Maybe Honda's infamous auto transmission technology has hit you where it hurts.
On the other hand, if you've exaggerated the symptoms, it could be an idle air control valve. That apparently is a VERY common failure in Hondas (I've had two fail, both on the same car, in 7 years; dealership isn't at all surprised).
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.