Civic Si '93, sudden no-start ? ideas ?

Civic Si '93 HB 5-spd MT 1.6L (225,214 Miles) (362,446 km)
Was Running great, had no warning signs, just got the emissions inspection, passed w/ comfortable margins.
Went to start and it just gave a good **strong** Wa.Wa.Wa.Wa.Wa.Wa.Wa (or Chuga, Chuga, Chuga if you prefer)
Diagnostics: The engine light is on (no blinks, just solid on) and i hear 6 long loud beeps after i turn key to ON.
Also i noticed some new quieter high pitched fast/short beeps that occur at same time as the other beeps (so 2 sets of beeps occur at same time) but different sequence ( it is 4 high pitched short beeps)
I tried the jumper wire on the service check connector and no blinks from the engine light, solid on.
I could not remember the start up noise/clicks/ light sequence, Is it ? Turn key on, hear two beeps. hear one click, hear slight hum, then hear another click and then start ???
Anyway, some ideas or suggestions would be greatly appreciated.
The little plastic pads look ok on the clutch and brake pedals, i have had that problem before
TIA, robb
BTW -- For those interested in emissions results.... 25/15 50/15 Allowed ------------------------------------------------------------------ HC ppm 62 48 153 / 159 CO % 0.15 0.11 0.66 / 0.89 NOx ppm 188 149 1123 / 1242 RPM 2019 1819 3000 max CO+CO2 % 15.0 14.2 6.0 min
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
robb wrote:

determine whether you have lost fuel or spark
if you lost spark, the most likely cause on a Honda that age is the distributor
if you lost fuel, the most likely on a Honda that old is the EFI Main Relay
GW
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.