Help 89 Acura Integra runs fine at idle, revs up smoothly but when you go to drive it , tends to bogg down like it's starving for fuel.??

Changed fuel filter,fuel pump and had the injectors cleaned still no help... Any suggestions would be greatly appreciated.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I have seen several Integras that had bad distributor cap/rotors with that same complaint.
David Short Acura God

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
does the vehicle have a check engine light on ?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
changed dist/cap and rotor plus wires and plugs still does the same thing. what is next?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
no check engine light but will look into the the dist/cap thing maybe that is the problem will get back to you with results... thanks for your input.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
do you know anyone lookin for a integra motor 92 low miliage please email me at snipped-for-privacy@aol.com
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.