Real-time traffic issue on 2005 RL

Hi,
I got my new 2005 RL at the end of last year. I love the car, but the one issue that I have is with the real-time traffic info that should be
displayed on the Nav system. It worked when the salesman delivered the car to me, but stopped working shortly after. The dealership is great, but tell me that it needs a software update that should be available in February. Are other owners seeing this problem? I live in the Boston area. Any info would be much appreciated.
Thanks, Chris.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The best website for all things Acura (besides the factory site) is www.acurazine.com They have a section devoted to the new RL.
They have over 55,000 members and lots of good info.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
To follow up on my original posting....Had the RL in for a set of recalls yesterday. One of the was to replace the Acuralink unit, which fixed the real-time traffic issue - it is now working properly! BTW, they also replace a speaker in the front-door - nothing wrong with it to my ears, but it was another recall. They also did something to the PCM system. Everything seems good now....
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Had my RL in for the updates on Monday. Everything was ok till then..
Now the doors keep trying to lock again anf the passenger side mirror does not always return to the preset position.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.