Shift and Brake lights on 2000 TL

My car will not shift out of Park. I start the engine, put my foot on the brake but the shifter will not move out of Park. I have to use a screwed
driver with the manual release and shift it into neutral before I start the engine. Has anybody had this problem. I also do not have any brake lights. Can anybody make a suggestion for repair?
Robert King
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

The missing brake lights are the key - the tranny doesn't believe the brake pedal is depressed. Start with a visual inspection of the switch that senses whether the brake pedal is depressed or not (usually on the driver side of the brake pedal arm) and check fuses. Once you get the brake lights working I'm confident the shifting will work.
Mike
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
thanks Michael. This group works. I was able to isolate the problem at the brake switch located by the brake pedal. A simple R&R of the switch and problem solved. Thanks again
Robert King

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Woo hoo! Thanks for the feedback... it will help the next guy, too.
Mike
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.