Speedometer problem

'98 3.2 TL, in excellent shape with 65K miles...
I've seen speedometers break. I've seen bouncing and/or floating needles, dry cable noise, but never this. Stopping for gas, then back onto the
freeway, up to about 65 MPH, but the speedo showed 48 MPH. The odometer appeared to be functioning fine. Finally, I couldn't take it any longer, so I pulled off. Back up to freeway speed, again only registering 48 MPH. Huh? It seems to work fine, as long as I don't exceed 48.
Unc
(.....but officer, I was only doing 48!)
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Low miles for that age!

I used to own a Dodge Polara with a mechanical speedo that would stick at 70-some MPH. When you banged on the dash,the needle would drop back down and work fine...until you got up to that certain speed where the needle sticks.
I'd guess you have a problem in the speedo. I doubt it would be the ECU or VSS,problems with those would cause other problems,too.Maybe you can find a wrecked TL and salvage the speedo for a test.Or salvage all those parts for test swaps. Or let the Acura dealer fix it.
It seems it would be worth the expense to get this auto repaired.
--
Jim Yanik
jyanik
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.