1990 V8 Sound system

I have a 1990 V8 with the Audi Bose sound system. The radio is now producing a high pitched squeal on all stations or when playing a tape (not associated
with engine speed) and the AM section has ceased to work entirely. Does anyone know of a replacement radio that will work with the Bose speaker system or someone who I can send the radio to for repair?
Thanks Bill
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Any VAG Audi dealer?
Ronald
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
S William Mote wrote:

The capacitors in the built-into-the-speaker amps are dying. I believe this was subject to a recent recall. Check with your friendly Audi dealer.
Kent '94 100 S Avant '89 200 TQ, "Bad Puppy"
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I believe that there is a unit that can be purchased to make aftermarket stereos work with the Bose speakers, I think it is called Audilink, I've seen them on Ebay before. When I bought my V8 the previous owner had bypassed the speaker mounted amplifiers directly at the speaker and disabled the amplifiers to install the aftermarket stereo, I have heard that the Bose speakers operate at 2 ohms instead of what a normal stereo operates at, I did notice a signifigant difference when I re-installed the factory stereo, it sounded much better.And where have you ever seen a friendly or helpful Audi dealer, LOL Good Luck John On Fri, 05 Nov 2004 20:43:54 GMT, Kent McLean

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.