1999 A6 Tran Problem?

Was doing about 75 mph on the freeway coming home from work earlier today when all of a sudden the car shudders like someone hit the car from behind.
Also felt like a slipping clutch that suddenly catches. After the momentary thud, off you go like nothing happened. Very intermittent as well. Did it three times on the way home and then later on in the evening at much slower city street speed (about 25-30 mph or so). Car is up to date on all service intervals. Has about 115K and engine runs very well. Have had the normal wear stuff replaced (e.g. engine - timing belt and water pump, suspension - boots, tie rod ends, new tires, etc).
Thanks for any feedback regarding what the problem might be.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I take it you are from the land of the "free" ;-) - so no doubt you have a slush box, rather than a stick! My gut feeling is that stored fault codes (DTCs), from both engine and tranny ECUs, would need to be pulled, and this would certainly help the initial diagnosis.
HTH, rgds, Sean
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks for the feedback, Sean. You are correct. I am an "ugly American" with a slush box. I'll see what I can do to pull the codes without going to the local Audi dealership as the cost is fairly high just to do the diagnostic.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.