2001 Audi Allroad Immobilizer trouble

Two weeks ago I replaced my 2002 Passat Wagon 4motion GLX with a 2001 Audi Allroad 2.7 Twin Turbo 6 speed. The only flaw the Audi has is the pixels in the center of the cluster.
So I ventured out, found and bought a used Allroad cluster on ebay. Of course you know what comes next. I installed it (I own a Mercedes Shop) and the car wouldn't stay running. I googled the issue and found out that I have the immobilizer generation 3 and that only the Audi dealer can program these clusters.
I called Checkered Flag in Virginia Beach, dead end, they refuse to install a "used cluster." Mad as hell I called the direct Audi of North America phone number in my paperwork. They told me installing a used cluster is at the discretion of each dealer and that they can't warranty parts I bring in myself.
They finally gave me phone number to the nest dealer in my area which is Audi in Richmond VA (over an hour away) I called them and they are happy to assist me with the installation of the used one.
Unreal, any thoughts on this ?
--Martin Bartloff
www.MartinBartloff.com
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Tuesday, March 17, 2009 11:51:38 AM UTC-4, Bnzmn600 wrote:

Question
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.