84 quattro oil buzzer

Hi all...
I have an 84 Quattro, about 172,000 miles on it. This morning I started it up and went out and noticed that the oil light would come on and a warning
buzzer sounded when I was changing gears (5 speed). Thinking it needed oil, I went back home but the level was fine and went out again. It seems that at 4500 rpm, any gear, the oil light comes on and the buzzer sounds. What is wrong?
TIA Rush
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Sounds like a bad oil pump. With a high RPM the pump cannot keep up the oil pressure so the warning light comes on. Or it is simply a half broken pressure sensor...
Al
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks Al, that is what I thought, gonna take in tomorrow... TIA

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Looked this morning at the wiring and lo and behold the wire was severed... I have a pack rat problem and every night open the hood and put a light in the engine compartment, well it looks like down where the High pressure sensor is still fine for them. They have eaten the wiring in several places already, I should have thought of that before. Someone told me they like the salts in certain plastic.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.