'88 Audi Coupe, Hazard light problem

Hello! My '88-9 Audi Coupe has a faulty Hazard light. It just stopped working the other day! I have replaced the switches and the relay (under the dash). The
indicators work fine, though. When I changed the switches over, the hazard light on the instrument panel came on constant. The indicator lights came on when the haz switch was on, but again, constant (not flashing). I re-plugged in the switch, and the light went out. Now i'm back to square one!!
Any suggestions?
Simon England
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Simon, Check the wiring to the switch - www.audifans.com notes problems with grounding for Coupe Hazard problems. Sounds like changing the switch (moving the wiring ~ broken wire? , flaky connections in the plug? Cheers! Steve Sears 1987 Audi 5kTQ 1980 Audi 5k 1962 and '64 Auto Union DKW Junior deLuxes (SPAM Blocker NOTE: Remove SHOES to reply)

The
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

The
Check the fuses. Last week I was driving without break lights for a few days... The hazard light did the same as yours, just goes on and stays on. Found a nice burned out fuse, replaced it and everything works fine again. It seems like the hazard light also runs on the same circuit as the break lights.
Al
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Check the wires entering the drivers side trunk hinge. They break and cause all kinds of odd problems.
'91 100q 5psd
Slimbo wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.