98 A6 Quattro heater, horn, turn signal, lights electrical problem

About two weeks ago I washed my car and later on that night, I developed problems with my driver side door indicator telling me the door was opened with all the bells and whistles going off. It so
happens, the temperture has dropped into the teens that last two weeks. I believe a switch froze in place after the car wash. Several days ago I took a fairly short trip with heater going on full blast. Parked the car and next day my heater blower was not working along with my horn, driving lights, turn signal, and windshield wipers. I checked all fuses and all were fine. When you turn on the headlight light switch, all the the parking lights come on except for the headlights. With the turn signal switch you can temporally switch on the high beams, but no headlights. To me it seems a relay dwitch associated with all these units "somewhere" is frozen in place or finally died out. I have no shop manuel so, Iam asking if anyone had similar problems.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Do you have wet carpets?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Ronny wrote:

I have not checked...I used to have a problem with water coming in through the cabinet air filter which is located right below the windshield on the passenger side. This is obviously a bad design. I had to put some silicon between the windshield and the black edging which came loose. Water could have filtered in through here. In the past it affected the blower motor, making it squeak.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.