98 A6Q Intermittent start problem

HI: New to the group here. Have a 98 A6 Quattro 2.8 144k miles.. heres my problem.. twice in past two months have had starting problem.. first time was mid Jan in NYC.. temp had dropped to single digits.. second time was
today.. temp had not gone too low over night .. but both times similar symptoms... engine had plenty of cranking power.. engine turned over and over... no weakening... both times when vehicle finally fired that engine was slow to "take".. like it was starrved for fuel or something.. needed to keep pedal depressed to keep engine firing... my hunch is a fuel problem..
Anyone out here have simialr problems or any suggestions? I am a sort of newbie mechanic.. that is I used to help my dad work on vehicles back in the 70s when u could stand in the engine compartment and work...lol havent dont much since..
Any advice greatly appreciated. Thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I have seen that problem if the engine is started and run from cold for say 10-15 seconds then turned off and left over night. Could that fit with your situation ? Rgds alec
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Alec.. Thanks.. but that doesnt apply to my situation.. enginew as run and shut normally previous night.. update! today I was idling in vehicle and noticed some intermittent sputtering in idle.. like a misfire or bad fuel ignition.. I will have to see if I am due for a tune up?? Only had this vehicle short time.. inherited from relative..
Thanks..

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.