A6 1.8T Engine Rattle

Hope someone can help me with this.
UK '99 A6 1.8T (150bhp) with 110K miles. Engine runs fine but have noticed over last few weeks that between gear changes when revs drop to approx.
2000rpm a rattle is heard from the engine. Noise doesn't occur when engine revs increase, only when decreasing. Does the same thing if sat stationary and rev engine.
It doesn't sound like a plate/heatshield etc rattling in the engine bay due to vibration, as I would expect this to vibrate at various rpm whether increasing revs or decreasing.
Certainly sounds like something in the engine like a chain rattling but don't know the internals of the engine very well to put my finger on it.
I would be grateful for any advice hopefully to tell my engine is not terminally ill or if I can expect an expensive trip to the dealer.
Thanks
Ian
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Check the timing belt tension. Open the cover at the front of the engine. It will open enough for you to see in with a torch. The toothed belt should be tight. If it is loose then do not drive the car.....
Rgds Alec

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks for advice, I checked the timing belt tension and it is fine. Having listened to the noise again it sounds like it's coming from the catalytic converter. I assume it's the cat which is bolted on just after the turbo and drops down by the bulkhead. Is it likely to be damaged inside and causing this noise?
Regards
Ian.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Hi,
I had something really similar with my 1.8T A4 a while back. Take a look : http://forums.audiworld.com/a4/msgs/1562680.phtml
Hope this helps
Micho
wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks for the feedback, it'll help when it goes in for its 110K mile service when I explain the problem. Apologies for lack of knowledge on engine, which end is the cam adjuster, as the noise sound like its coming from the back of the engine down low (bulkhead end).
Regards
Ian.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks for the feedback, it'll help when it goes in for its 110K mile service when I explain the problem. Apologies for lack of knowledge on engine, which end is the cam adjuster, as the noise sound like its coming from the back of the engine down low (bulkhead end).
Regards
Ian.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Actually I have no idea where a "cam adjuster" is. If I had to take a guess it would be in the middle-top part or the engine, but then again, its just a guess. All I really know that it was bugging me a lot until the dealer finally found it.
Micho
wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.